Kumpulan Perintah-perintah Dasar Mikrotik RouterOS

|| || || Leave a komentar
Bagi anda yang baru belajar menggunakan Mikrotik pasti masih bingung dengan perintah (command line) yang digunakan pada RouterOS. Padahal banyak perintah-perintah dasar Mikrotik yang penting dan wajib diketahui agar anda dapat menggunakan Mikrotik RouterOS dengan baik. Sebenarnya perintah–perintah dasar MikroTik RouterOS tidak jauh berbeda dengan perintah dasar pada linux umumnya. Karena sebetulnya mikrotik ini merupakan perkembangan dari kernel linux Debian.Kumpulan Perintah-perintah Dasar Mikrotik RouterOS - Bagi anda yang baru belajar menggunakan Mikrotik pasti masih bingung dengan perintah (command line) yang digunakan pada RouterOS. Padahal banyak perintah-perintah dasar Mikrotik yang penting dan wajib diketahui agar anda dapat menggunakan Mikrotik RouterOS dengan baik. Sebenarnya perintah–perintah dasar MikroTik RouterOS tidak jauh berbeda dengan perintah dasar pada linux umumnya. Karena sebetulnya mikrotik ini merupakan perkembangan dari kernel linux Debian.

Perintah shell Mikrotik RouterOS sama dengan linux, seperti penghematan perintah, cukup menggunakan tombol TAB di keyboard maka perintah yang panjang, tidak perlu lagi diketikkan, hanya ketikkan awal nama perintahnya, nanti secara otomatis Shell akan menampilkan sendiri perintah yang berkenaan. Misalnya perintah IP ADDRESS di mikrotik. Cukup hanya mengetikkan IP ADD spasi tekan tombol TAB, maka otomatis shell akan mengenali dan menterjemahkan sebagai perintah IP ADDRESS.

Berikut ini merupakan perintah perintah dasar Mikrotik yang umum digunakan :



1. Perintah untuk shutdown dan restart computer , ketikkan :
[admin@MikroTik]>system shutdown  (Untuk shutdown komputer )
[admin@MikroTik]>system reboot       (Untuk restart computer )
[admin@MikroTik]>system reset   (Untuk meret konfigurasi yang sudah dibuat sebelumnya). Dan perlu diperhatikan bahwa perintah – perintah tersebut harus dilakukan pada direktori admin.

2. Perintah untuk merubah nama mesin Mikrotik , ketikkan :
[admin@MikroTik]>/system identity
[admin@MikroTik]>system identity > set name=proxy
Untuk melihat hasil konfigurasi , ketikkan “print” atau  “pr”
Contok [admin@MikroTik]system indentity>pr name:”proxy”
Lalu console berubah menjadi [admin@proxy]

3. Perintah merubah password mesin MikroTik , ketikkan
[admin@proxy]>/ password
[admin@proxy]password>old password (jika sebelumnya anda belum mengeset password maka ketikkan kosong)
[admin@proxy]password>new password :……(ketikkan password yang baru)
[admin@proxy]password>retype new password: ……..(masukkan sekali lagi passowrdnya)

Sebagai contoh :
Jika  password lama kosong dan password baru ABCD, maka perintahnya adalah sebagai berikut :
[admin@proxy]>/password
[admin@proxy]password>old password
[admin@proxy]password>new password ABCD
[admin@proxy]password>retype new password ABCD

4. Perintah untuk melihat kondisi interface pada Mikrotik Router :
[admin@Mikrotik] > interface print
Flags: X – disabled, D – dynamic, R – running
#    NAME                         TYPE             RX-RATE    TX-RATE    MTU
0  R ether1                        ether            0          0          1500
1  R ether2                       ether            0          0          1500
[admin@Mikrotik]>
Jika interfacenya ada tanda X (disabled) setelah nomor (0,1), maka periksa lagi
etherned cardnya, seharusnya R (running).
a. Mengganti nama interface
    [admin@Mikrotik] > interface(enter)
b. Untuk mengganti nama Interface ether1 menjadi Public (atau tersenamanya),maka:      
    [admin@Mikrotik] interface> set 0 name=Public
c. Begitu juga untuk ether2, misalkan namanya diganti menjadi Local, maka
    [admin@Mikrotik] interface> set 1 name=Local
d. atau langsung saja dari posisi root direktori, memakai tanda “/”, tanpa tanda kutip
    [admin@Mikrotik] > /interface set 0 name=Public
e. Cek lagi apakah nama interface sudah diganti.
    [admin@Mikrotik] > /interface print
    Flags: X – disabled, D – dynamic, R – running
   #    NAME                         TYPE             RX-RATE    TX-RATE    MTU
   0  R Local                        ether            0          0          1500
   1  R Public                       ether            0          0          1500

5. Perintah untuk melihat paket sofwtware MikroTik OS :
[admin@proxy]>/system package
[admin@proxy]system package><ketikkan print atau pr>
Dengan perintah diatas maka akan tampil paket softwore yang ada dalam MikroTik Os Contoh :
[admin@MikroTik  system package> pr
Flags : x – disabled
 #       Name
0   X routing – test
1   dhcp
2   radiolan
3   user-menejer
4   X webproxy-test
5   arlan
6   isdn
7   hotspot-fix
8   ppp
9   wireless
10  web-proxy
11  hotspot
12  advanced-tools
13  security
14  Telephony
15  routing
16  synchronous
17  system
18  routerboard
19  rstp-bridge-test
20  X wireless-legecy
VERSION
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27

SCHEDULED
Untuk  melihat lebih detailnya, ketikan :
     [admin@proxy]system package > pr detail fl           gs : x – disabled
0         x name=”routing-test” version=”2.9.27” build – time =jul/03/2006 10:57:53 scheduled
1         name =”system”version =”2.9.27” build – time=jul/03/2006 10 :56:37 schedule
2         name =”system”version =”2.9.27” build – time=jul/03/2006 10 :56: 44  schedule
3         name=”web-proxy” version=”2.9.27” build-time=jul/03/2006 10:`58 :03 schedule
4         name=”advanced –tools” version=”2.9.27” build –time=jul /03/2006 10:56 : 41 scheduled=””
5         name=”dhcp” version=”2.9.27” build-time=jul/03/2006 10:56:45 scheduled=””
6         name =”hotspot”version=”2.9.27”build-time=jul/03/2006 10:56:58 scheduled=””
7         x name=”webproxy-test” version=”2.9.27” build-time=jul / 03 /2006 10:57:52 scheduled
8         name=”routerboard” version =”2.9.27” build-time=jul / 03 / 2006 10: 57 : 17 –[q quit‌  ׀ D dump ׀ up ׀ down ]


6. Perintah untuk mengupgrade paket software router :
[admin@Mikrotik] system upgade>
To upgrade chosen packages :
Download 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14

7. Perintah mengaktifkan paket software yang ada dalam MikroTik OS :
    [admin@Mikrotik]system page>
     Enable <ketikkan paket yang dikehendaki>
Contoh :
[admin@proxy] system package> enable dhcp

8. Perintah merubah nama ethernet pada mesin MikroTik OS:
[admin@proxy]>/interface
[admin@proxy]interface>ethernet set etherl nama=public
Atau dengan menggunakan perintah
[admin@proxy]interface>set<ketikan number ethernet yang terpasang>
 name=<nama ethernet   yang baru >
contoh :
[admin@proxy]interface> set 0 name=public
[admin@proxy]interface>set 1 name=lan
Atau
[admin@proxy]interface>
set 0 name=public; set 1 name=lan

9
. Perintah setting IP address pada mesin MikroTik OS :
[admin@proxy]> ip address
[admin@proxy]ip address>
Add interface=<nama interface>anddress=
(ketikkan IP address/subnet mask interface)
Contoh :
Jika nama interfacenya “lan” dan IP address yang dikehendaki : 192.168.01 dan subnet mask : 255.255.255.0, maka perintahnya  sebagai berikut
[admin@proxy]>/ ip address
[admin@proxy]ip address >
Add interface=lan address = 192.168.0.1/24

10. Perintah setting IP DNS primaty dan Secondary :
[admin@proxy]./ip dns
[admin@proxy]ip dns>
Set nama-dns>=<Ip dns dari ISP>

Contoh :
Jika IP DNS primary ISP : 202.134.1.10 dan secondary:
202.134.0.0155, maka perintahnya adalah sebagai berikut :
[admin@proxy]./ip dns
[admin@proxy]ip dns>
Set primary-dns= 202.134.1.10
[admin@proxy]ip dns>
Set secondary-dns=202.134.0.155

11. Perintah setting IP Gateway pada mesin MikroTik OS
[admin@proxy]>/ip route
[admin@proxy]ip route >add gateway=<ip gatway
Contoh IP gateway  dari ISP : 202.134.1.1, maka perintahnya :
[admin@proxy]>/ ip route
[admin@proxy] ip route>
add  gateway=202.134.1.1

12. Perintah Network address Translate (NAT) pada mesin MikroTik OS
[admin@proxy]>/ip firewall nat
[admin@proxy]ip firewall nat>
add  chain=srcnat out-interface=<etherface yang terhubung
dengan jaringan WAN> scr-address=
<network-id interface yang terhubung dengan LAN / subnet mask interface
LAN> action=masqurade

Contoh :
jika network-id interface LAN :”192.168.0.0” dan subnet
Mask :”255.255.255.0”. untuk interface mesin MikroTik OS yang terhubung ke jaringan
WAN : “pubilk”, maka perintahnya sebagai berikut :
[admin@proxy] >/ip firewall nat
[admin@proxy[ ip firewall nat>
Add chain=srcnat out-interface=public
Scr-address=192.168.0.0/24 action=masquerade



4 Cara Mengakses Mikrotik

|| || || Leave a komentar
Perangkat Mikrotik dapat diakses dengan menggunakan berbagai media, dan cara akses Mikrotik nya pun berbeda-beda. Ada 4 cara mengakses MikroTik Router, antara lain :

  • Via Console/Command Mikrotik
Mikrotik bisa  kita akses langsung  via console/shell maupun remote akses menggunakan PUTTY (www.putty.nl). Caranya tinggal masukkan alamat IP Mikrotik ke kolom Host Name nya PuTTY.
 1. Tips Command : "Manfaatkan auto complete" (mirip bash auto complete di linux) Tekan Tombol TAB di keyboard untuk mengetahui/melengkapi daftar perintah selanjutnya. Jadi perintah yang panjang tidak perlu kita ketik lagi, cukup ketikkan awal perintah itu, lalu tekan TAB-TAB maka otomatis Shell  akan menampilkan/melengkapi daftar perintah yang kita maksud.

CONTOH:
Cukup  ketikkan Ip Fir >>> lalu tekan TAB  >>> maka otomatis  shell akan melengkapi menjadi Ip Firewall. Lalu ketik “..” (titik dua) untuk kembali ke sub menu diatasnya, dan ketik “/“ untuk kembali ke root menu.

  • Via Web Browser
Mikrotik bisa juga di akses via web/port 80 pada browser. Contoh : ketik di browser IP mikrotik kita: 192.168.1.10.
  • Via Winbox
Mikrotik  bisa  juga diakses/remote  menggunakan  tool  winbox (utility kecil di windows yang sangat praktis dan cukup mudah digunakan). Winbox merupakan tool untuk meremote Mikrotik yang paling populer karena selain mudah juga dapat menampilkan menu-menu pada Mikrotik secara GUI. Tampilan awal mengaktifkan winbox seperti ini :  
Winbox bisa mendeteksi mikrotik yang sudah di install asal masih dalam satu network, yaitu dengan mendeteksi MAC address dari ethernet yang terpasang di Mikrotik. Untuk bisa mengakses mikrotik menggunakan winbox bisa dengan menggunakan IP Address Mikrotik maupun MAC Address nya.
  • Via Telnet 
 
Kita dapat me-remote MikroTik menggunakan telnet melalui program aplikasi ”command prompt” (cmd)  yang ada pada windows yang fitur Telnet nya sudah diaktifkan. Namun, penggunaan telnet tidak dianjurkan dalam jaringan karena masalah keamanannya.

CONTOH: